<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel="pingback" href="https://neptunepine.com/xmlrpc.php"><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /> <!-- This site is optimized with the Yoast SEO plugin v17.8 - https://yoast.com/wordpress/plugins/seo/ --><style media="all">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</style><title>Ram Charan As Desi Iron Man? Fan Tweet Demanding &#039;RRR&#039; Actor To Play Robert Downey Jr&#039;s Marvel Character Goes Viral - Neptune Pine</title><link rel="canonical" href="https://in.mashable.com/entertainment/33878/ram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Ram Charan As Desi Iron Man? Fan Tweet Demanding &#039;RRR&#039; Actor To Play Robert Downey Jr&#039;s Marvel Character Goes Viral - Neptune Pine" /><meta property="og:description" content="After a phenomenal run at the box office, SS Rajamouli&#8217;s period drama &#8216;RRR&#8217; continues to soar in the digital world post its arrival on Netflix. The film starring Ram Charan and Jr NTR has become an international blockbuster with several renowned Hollywood personalities praising Rajamouli&#8217;s cinematic brilliance. But what has grabbed our attention is a&hellip;" /><meta property="og:url" content="https://neptunepine.com/ram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character-goes-viral/" /><meta property="og:site_name" content="Neptune Pine" /><meta property="article:published_time" content="2022-06-24T08:21:42+00:00" /><meta property="article:modified_time" content="2022-06-24T08:21:52+00:00" /><meta property="og:image" content="https://i1.wp.com/neptunepine.com/wp-content/uploads/2022/06/ram-charan-as-iron-man-copy1_bc8u.jpg?fit=2100%2C1268&#038;ssl=1" /><meta property="og:image:width" content="2100" /><meta property="og:image:height" content="1268" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="John Colin" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="2 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://neptunepine.com/#website","url":"https://neptunepine.com/","name":"Neptune Pine","description":"","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://neptunepine.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://in.mashable.com/entertainment/33878/ram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/neptunepine.com/wp-content/uploads/2022/06/ram-charan-as-iron-man-copy1_bc8u.jpg?fit=2100%2C1268&ssl=1","contentUrl":"https://i1.wp.com/neptunepine.com/wp-content/uploads/2022/06/ram-charan-as-iron-man-copy1_bc8u.jpg?fit=2100%2C1268&ssl=1","width":2100,"height":1268},{"@type":"WebPage","@id":"https://in.mashable.com/entertainment/33878/ram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character#webpage","url":"https://in.mashable.com/entertainment/33878/ram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character","name":"Ram Charan As Desi Iron Man? Fan Tweet Demanding &#039;RRR&#039; Actor To Play Robert Downey Jr&#039;s Marvel Character Goes Viral - Neptune Pine","isPartOf":{"@id":"https://neptunepine.com/#website"},"primaryImageOfPage":{"@id":"https://in.mashable.com/entertainment/33878/ram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character#primaryimage"},"datePublished":"2022-06-24T08:21:42+00:00","dateModified":"2022-06-24T08:21:52+00:00","author":{"@id":"https://neptunepine.com/#/schema/person/0360c2245d8a695882f666c36f5a031e"},"breadcrumb":{"@id":"https://in.mashable.com/entertainment/33878/ram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://in.mashable.com/entertainment/33878/ram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character"]}]},{"@type":"BreadcrumbList","@id":"https://in.mashable.com/entertainment/33878/ram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://neptunepine.com/"},{"@type":"ListItem","position":2,"name":"Ram Charan As Desi Iron Man? Fan Tweet Demanding &#039;RRR&#039; Actor To Play Robert Downey Jr&#039;s Marvel Character Goes Viral"}]},{"@type":"Person","@id":"https://neptunepine.com/#/schema/person/0360c2245d8a695882f666c36f5a031e","name":"John Colin","image":{"@type":"ImageObject","@id":"https://neptunepine.com/#personlogo","inLanguage":"en-US","url":"https://i0.wp.com/neptunepine.com/wp-content/uploads/2019/11/John-Colin.jpg?fit=96%2C72&ssl=1","contentUrl":"https://i0.wp.com/neptunepine.com/wp-content/uploads/2019/11/John-Colin.jpg?fit=96%2C72&ssl=1","caption":"John Colin"},"description":"I am a technology journalist with over two decades of press experience. I have spent much of the last ten years, focusing on open source, tech gadgets, data analytics and intelligence, Internet of things, cloud computing, mobile devices, and data management. I'm a senior editor at Mashable's covering data analytics, venture capital, (SaaS) applications, cloud and enterprise software out of New York.","url":"https://neptunepine.com/author/john/"}]}</script> <!-- / Yoast SEO plugin. --><link rel="amphtml" href="https://neptunepine.com/ram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character-goes-viral/amp/" /><meta name="generator" content="AMP for WP 1.0.77.33"/><link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel='dns-prefetch' href='//i0.wp.com' /><link rel='dns-prefetch' href='//i1.wp.com' /><link rel='dns-prefetch' href='//i2.wp.com' /><link rel='dns-prefetch' href='//c0.wp.com' /><link rel="alternate" type="application/rss+xml" title="Neptune Pine &raquo; Feed" href="https://neptunepine.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Neptune Pine &raquo; Comments Feed" href="https://neptunepine.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Neptune Pine &raquo; Ram Charan As Desi Iron Man? Fan Tweet Demanding &#039;RRR&#039; Actor To Play Robert Downey Jr&#039;s Marvel Character Goes Viral Comments Feed" href="https://neptunepine.com/ram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character-goes-viral/feed/" /><link rel='stylesheet' id='sab_font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=5.8.4' type='text/css' media='all' /><link rel='stylesheet' id='sitebox-custom-fonts-css'  href='//fonts.googleapis.com/css?family=Odor+Mean+Chey%3Aregular%7COpen+Sans%3Aregular%2Citalic%2C700%2C300%26subset%3Dlatin%2C' type='text/css' media='all' /> <script type='text/javascript' src='https://neptunepine.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <!--[if lte IE 9]> <script type='text/javascript' src='https://neptunepine.com/wp-content/themes/sitebox/assets/js/html5shiv.min.js' id='sitebox-html5-js'></script> <![endif]--><link rel="https://api.w.org/" href="https://neptunepine.com/wp-json/" /><link rel="alternate" type="application/json" href="https://neptunepine.com/wp-json/wp/v2/posts/858455" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://neptunepine.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://neptunepine.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.8.4" /><link rel='shortlink' href='https://neptunepine.com/?p=858455' /><link rel="alternate" type="application/json+oembed" href="https://neptunepine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fneptunepine.com%2Fram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character-goes-viral%2F" /><link rel="alternate" type="text/xml+oembed" href="https://neptunepine.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fneptunepine.com%2Fram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character-goes-viral%2F&#038;format=xml" /><meta name="generator" content="Feed to Post 3.15.1" /> <!-- Begin Custom CSS --> <!-- End Custom CSS --><meta name="google-site-verification" content="VnYxLfoH33N57aIJFL15rqIWX8VHcJaXPOaaZxLe478" /> <script src="https://neptunepine.com/wp-content/cache/autoptimize/js/autoptimize_e2b5eebf5481a328857d605bda791b5d.js"></script></head><body class="wordpress ltr parent-theme y2022 m06 d26 h01 sunday logged-out custom-background singular singular-post singular-post-858455 post-format- multi-author single layout-2c-l" dir="ltr" itemscope="itemscope" itemtype="http://schema.org/Blog"><div id="page" class="hfeed site clearfix"> <!-- Masthead / Start --><header id="masthead" class="site-header header clearfix" itemscope="itemscope" itemtype="http://schema.org/WPHeader"> <!-- Primary Bar / Start --><div id="primary-bar" class="clearfix"><div class="container inner"><nav id="primary-nav" class="top-navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"><ul id="primary-menu" class="sf-menu"><li  id="menu-item-372" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-372"><a href="https://neptunepine.com/about-us/">About Us</a></li><li  id="menu-item-373" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-373"><a href="https://neptunepine.com/become-a-contributor/">Become a Contributor</a></li><li  id="menu-item-374" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-374"><a href="https://neptunepine.com/contact-us/">Contact Us</a></li><li  id="menu-item-559" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-559"><a href="https://neptunepine.com/our-team/">Our Team</a></li><li  id="menu-item-375" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-375"><a href="https://neptunepine.com/privacy-policy/">Privacy Policy</a></li></ul></nav><!-- #site-navigation --><div class="header-search"><form method="get" id="searchform" action="https://neptunepine.com/"> <button type="submit" id="search-submit" class="fa fa-search"></button> <input type="search" name="s" id="s" placeholder="Search Our Site" autocomplete="off" value=""></form></div><!-- .header-search --></div><!-- .container --></div> <!-- Primary Bar / End --><div id="secondary-bar" class="clearfix"><div class="container"><div id="logo"><h1 class="site-title" id="site-title" class="site-title" itemprop="headline"><a href="https://neptunepine.com" itemprop="url" rel="home"><span itemprop="headline">Neptune Pine</span></a></h1><p class="site-description" id="site-description" class="site-description" itemprop="description"></p></div><nav id="secondary-nav" class="main-navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"><ul id="secondary-menu" class="sf-menu"><li  id="menu-item-357" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-357"><a href="https://neptunepine.com/category/business/">Business</a></li><li  id="menu-item-358" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-358"><a href="https://neptunepine.com/category/health/">Health</a></li><li  id="menu-item-238931" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-238931"><a href="https://neptunepine.com/category/science/">Science</a></li><li  id="menu-item-360" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-360"><a href="https://neptunepine.com/category/technology/">Technology</a></li></ul></nav><!-- #site-navigation --></div><!-- .container --></div></header> <!-- Masthead / End --><main id="main" class="site-main container clearfix"><div id="primary" class="content-area"><div id="content"><article id="post-858455" class="entry author-john post-858455 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment" itemscope="itemscope" itemtype="http://schema.org/BlogPosting" itemprop="blogPost"><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://neptunepine.com/wp-content/themes/sitebox/assets/img/logo-colored.png"><meta itemprop="width" content="300"><meta itemprop="height" content="80"></div><meta itemprop="name" content="Neptune Pine"></div><header class="entry-header wrap"><h1 class="entry-title" itemprop="headline">Ram Charan As Desi Iron Man? Fan Tweet Demanding &#039;RRR&#039; Actor To Play Robert Downey Jr&#039;s Marvel Character Goes Viral</h1><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://neptunepine.com/ram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character-goes-viral/" content="Ram Charan As Desi Iron Man? Fan Tweet Demanding &#039;RRR&#039; Actor To Play Robert Downey Jr&#039;s Marvel Character Goes Viral" /><div class="entry-meta clearfix"> <span class="date"> <span>Posted on</span> June 24, 2022<meta class="entry-published updated" content="2022-06-24T08:21:42+00:00" itemprop="datePublished" title="Friday, June 24, 2022, 8:21 am" /><meta itemprop="dateModified" content="2022-06-24T08:21:52+00:00"/> </span> <span class="author vcard" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person"> by <a class="url fn n" href="https://neptunepine.com/author/john/" itemprop="url"><span itemprop="name">John Colin</span></a> </span> <span class="entry-like"><a href="#" class="none" id="tj-likes-858455" title="Like this"><i class="fa fa-heart"></i> <span class="tj-likes-count">0</span></a></span> <span class="entry-comments"> Comments<a href="https://neptunepine.com/ram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character-goes-viral/#respond" itemprop="discussionURL">0</a> </span></div><!-- .entry-meta --></header><div class="entry-content wrap clearfix" itemprop="articleBody"><p>After a phenomenal run at the box office, SS Rajamouli&#8217;s period drama &#8216;RRR&#8217; continues to soar in the digital world post its arrival on Netflix. The film starring Ram Charan and Jr NTR has become an international blockbuster with several renowned Hollywood personalities praising Rajamouli&#8217;s cinematic brilliance. But what has grabbed our attention is a fan tweet praising Ram Charan that continues to gain momentum on social media.</p><p>Taking to the microblogging platform, the fans wrote, &#8220;Missing Ram Charan + Reading Iron Man Comics. Now I want RC to play Tony Stark,&#8221; followed by another tweet that read: &#8220;See. LOOK. The way RC plays the complexity of Raju, the grief, the sacrifice, the way he makes you empathise with his utilitarian “greater good” ideal, the way he is larger than life, charismatic, brilliant, and is prettier than the rest of the universe put together?!??&#8221;</p><blockquote class="twitter-tweet" readability="13.418530351438"><p dir="ltr" lang="en">See. LOOK. The way RC plays the complexity of Raju, the grief, the sacrifice, the way he makes you empathise with his utilitarian “greater good” ideal, the way he is larger than life, charismatic, brilliant, and is prettier than the rest of the universe put together?!??</p><p>— Rin (@GrinchReality) <a rel="nofollow" href="https://twitter.com/GrinchReality/status/1539864979918458881?ref_src=twsrc%5Etfw">June 23, 2022</a></p></blockquote><p>The tweet demanding Ram Charan to play Marvel&#8217;s Iron Man/Tony Stark (essayed by Robert Downey Jr.) instantly grabbed desi-MCU fans attention. And within no time, the fan-tweet was flooded with exciting tweets featuring different versions of Ram Charan as Iron Man. Check them out here:</p><blockquote class="twitter-tweet" readability="2.8846153846154"><p dir="ltr" lang="en">It would be cool If <a rel="nofollow" href="https://twitter.com/AlwaysRamCharan?ref_src=twsrc%5Etfw">@AlwaysRamCharan</a> play&#8217;s Iron man ! <a rel="nofollow" href="https://t.co/z3c4QVb8V1">pic.twitter.com/z3c4QVb8V1</a></p><p>— Suryakanta Behera (@iHappy000) <a rel="nofollow" href="https://twitter.com/iHappy000/status/1539948781692518401?ref_src=twsrc%5Etfw">June 23, 2022</a></p></blockquote><blockquote class="twitter-tweet" readability="3.2110091743119"><p dir="ltr" lang="en">Ramcharan as Super Hero for you ❤ <a rel="nofollow" href="https://t.co/Jt1oZKynJN">pic.twitter.com/Jt1oZKynJN</a></p><p>— JusLikeVikki (@JuslikeVikki) <a rel="nofollow" href="https://twitter.com/JuslikeVikki/status/1539944347436982272?ref_src=twsrc%5Etfw">June 23, 2022</a></p></blockquote><blockquote class="twitter-tweet"><p dir="ltr" lang="und">🥰🥰🥰🥳🤩🤩</p><p>— Detective (@ChittiDetective) <a rel="nofollow" href="https://twitter.com/ChittiDetective/status/1539898889410867200?ref_src=twsrc%5Etfw">June 23, 2022</a></p></blockquote><p>Check out our version of desi-Iron Man Ft. Ram Charan:</p><figure itemscope itemtype="https://schema.org/ImageObject"><img alt class="image photo" itemprop="contentUrl" src="https://i1.wp.com/neptunepine.com/wp-content/uploads/2022/06/ram-charan-as-iron-man-copy1_bc8u.jpg?w=800&#038;ssl=1" data-recalc-dims="1" /></figure><p>On the other hand, Ram Charan is reported to make a special appearance in Salman Khan&#8217;s upcoming movie &#8216;Kabhi Eid Kabhi Diwali&#8217;. He is likely to show off his dancing skills with the Bhaijaan of Bollywood in the Farhad Samji directorial, currently scheduled to release in theatres on December 30, 2022.</p><p><strong><i>SEE ALSO: <a rel="nofollow" href="https://in.mashable.com/entertainment/33742/ram-charan-and-jr-ntr-starrer-rrr-beats-top-gun-maverick-the-batman-to-emerge-as-the-best-movie-of-2">Ram Charan And Jr NTR Starrer &#8216;RRR&#8217; Beats &#8216;Top Gun: Maverick&#8217; &amp; &#8216;The Batman&#8217; To Emerge As The Best Movie Of 2022</a></i></strong></p><p>Cover Image: Twitter</p><hr/><div class="dcms_author-info"><div class="dcms_author-avatar"> <img width="96" height="72" src="https://i0.wp.com/neptunepine.com/wp-content/uploads/2019/11/John-Colin.jpg?fit=96%2C72&amp;ssl=1" class="avatar avatar-96 photo jetpack-lazy-image" alt="" loading="lazy" data-lazy-src="https://i0.wp.com/neptunepine.com/wp-content/uploads/2019/11/John-Colin.jpg?fit=96%2C72&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></div><h3 class="dcms_author-heading">John Colin</h3><div class="dcms_author-description"> I am a technology journalist with over two decades of press experience. I have spent much of the last ten years, focusing on open source, tech gadgets, data analytics and intelligence, Internet of things, cloud computing, mobile devices, and data management. I'm a senior editor at Mashable's covering data analytics, venture capital, (SaaS) applications, cloud and enterprise software out of New York.</div><div class="dcms_author-footer"><div class="dcms_author-social"></div><div class="dcms_author-show-all"> <a href="https://neptunepine.com/author/john/">View all posts <i class="fa fa-angle-right" aria-hidden="true"></i></a></div></div></div><p><a rel="nofollow" href="https://in.mashable.com/entertainment/33878/ram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character">Source Link</a> : Ram Charan As Desi Iron Man? Fan Tweet Demanding &#039;RRR&#039; Actor To Play Robert Downey Jr&#039;s Marvel Character Goes Viral</p></div><footer class="entry-footer wrap clearfix"> <span class="entry-category" itemprop="articleSection"> <a href="https://neptunepine.com/category/entertainment/">Entertainment</a> </span><!-- .entry-category --> <span class="entry-share"> Share: <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fneptunepine.com%2Fram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character-goes-viral%2F" target="_blank"><i class="fa fa-facebook"></i></a> <a href="https://twitter.com/intent/tweet?text=Ram+Charan+As+Desi+Iron+Man%3F+Fan+Tweet+Demanding+%26%23039%3BRRR%26%23039%3B+Actor+To+Play+Robert+Downey+Jr%26%23039%3Bs+Marvel+Character+Goes+Viral&amp;url=https%3A%2F%2Fneptunepine.com%2Fram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character-goes-viral%2F" target="_blank"><i class="fa fa-twitter"></i></a> <a href="https://plus.google.com/share?url=https%3A%2F%2Fneptunepine.com%2Fram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character-goes-viral%2F" target="_blank"><i class="fa fa-google-plus"></i></a> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fneptunepine.com%2Fram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character-goes-viral%2F&amp;title=Ram+Charan+As+Desi+Iron+Man%3F+Fan+Tweet+Demanding+%26%23039%3BRRR%26%23039%3B+Actor+To+Play+Robert+Downey+Jr%26%23039%3Bs+Marvel+Character+Goes+Viral" target="_blank"><i class="fa fa-linkedin"></i></a> <a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fneptunepine.com%2Fram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character-goes-viral%2F&amp;media=https%3A%2F%2Fneptunepine.com%2Fwp-content%2Fuploads%2F2022%2F06%2Fram-charan-as-iron-man-copy1_bc8u.jpg" target="_blank"><i class="fa fa-pinterest"></i></a> </span></footer></article><!-- #post-## --><div id="comments" class="comments-area"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"><span>Leave a Reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/ram-charan-as-desi-iron-man-fan-tweet-demanding-rrr-actor-to-play-robert-downey-jrs-marvel-character-goes-viral/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://neptunepine.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="7" aria-required="true"></textarea></p><p class="comment-form-desc">Your email address will not be published. Required fields are marked <span class="required">*</span></p><p class="comment-form-author"><input class="txt" id="author" name="author" type="text" value="" size="30" placeholder="Name *" aria-required='true' /></p><p class="comment-form-email"><input class="txt" id="email" name="email" type="email" value="" size="30" placeholder="Email *" aria-required='true' /></p><p class="comment-form-url"><input class="txt" id="url" name="url" type="url" value="" size="30" placeholder="Website" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit btn" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='858455' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p></form></div><!-- #respond --></div><!-- #comments --><div class="post-nav"><div class="nav-prev"> <a href="https://neptunepine.com/centrica-to-recruit-ex-forces-personnel-for-green-energy-drive/" rel="prev"><div class="arrow"><i class="fa fa-angle-left"></i></div><div class="nav-text"><span>Previous Post</span><h5>Centrica to recruit ex-forces personnel for green energy drive</h5></div></a></div><div class="nav-next"> <a href="https://neptunepine.com/nba-draft-2022-paolo-banchero-joins-orlando-magic-as-first-pick/" rel="next"><div class="arrow"><i class="fa fa-angle-right"></i></div><div class="nav-text"><span>Next Post</span><h5>NBA Draft 2022: Paolo Banchero joins Orlando Magic as first pick</h5></div></a></div></div><!-- .loop-nav --></div><!-- #content --></div><!-- #primary --><div id="secondary" class="widget-area widget-primary sidebar column" aria-label="Primary Sidebar" role="complementary" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><aside id="search-1" class="widget widget_search"><form method="get" class="searchform" id="searchform" action="https://neptunepine.com/"><div> <input type="text" class="field" name="s" id="s" placeholder="Search" value=""></div></form></aside><aside id="recent-posts-3" class="widget widget_recent_entries"><h3 class="widget-title">Trending</h3><ul><li> <a href="https://neptunepine.com/glastonbury-live-paul-mccartney-headlines-saturday-on-the-pyramid-stage/">Glastonbury live: Paul McCartney headlines Saturday on the Pyramid Stage</a></li><li> <a href="https://neptunepine.com/sir-paul-mccartney-electrifies-glastonbury-with-guests-springsteen-and-grohl/">Sir Paul McCartney electrifies Glastonbury with guests Springsteen and Grohl</a></li><li> <a href="https://neptunepine.com/temp-worker-charged-with-murder-after-shooting-at-illinois-auto-parts-facility-kills-one-injures-two/">Temp worker charged with murder after shooting at Illinois auto parts facility kills one, injures two</a></li><li> <a href="https://neptunepine.com/prince-charles-wants-slave-trade-to-be-taught-as-widely-as-holocaust/">Prince Charles ‘wants slave trade to be taught as widely as Holocaust’</a></li><li> <a href="https://neptunepine.com/paul-mccartney-review-glastonbury-2022-its-a-historic-privilege-just-to-be-alive-at-the-same-time-as-him/">Paul McCartney review, Glastonbury 2022: It’s a historic privilege just to be alive at the same time as him</a></li><li> <a href="https://neptunepine.com/prince-charles-faces-questions-over-claims-he-accepted-e1m-cash-in-suitcase-from-qatari-sheikh/">Prince Charles faces questions over claims he ‘accepted €1m cash in suitcase from Qatari Sheikh’</a></li><li> <a href="https://neptunepine.com/gregor-townsend-took-a-lot-of-positives-from-scotland-as-victory-over-chile/">Gregor Townsend took ‘a lot of positives’ from Scotland A’s victory over Chile</a></li></ul></aside></div><!-- #secondary --></main> <!-- Site Main / End --> <!-- Footer / Start --><footer class="footer2 clearfix" id="footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter"> <!-- Site Bottom / Start --><div class="site-bottom clearfix"><div class="container"><div class="copyright"> &copy; 2019 |  Neptune Pine <a class="back-to-top" href="#top">back to top <i class="fa fa-angle-up"></i></a></div><!-- .copyright --></div><!-- .container --></div><!-- .site-bottom --> <!-- Site Bottom / End --></footer> <!-- Footer / End --></div><!-- #page --> <script type="text/javascript">/* <![CDATA[ */ jQuery(document).ready( function() { jQuery.post( "https://neptunepine.com/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "a23c19db80", post_id : 858455 } ); } ); /* ]]> */</script> <script type='text/javascript' src='https://neptunepine.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.7' id='regenerator-runtime-js'></script> <script type='text/javascript' src='https://neptunepine.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script> <script src='https://stats.wp.com/e-202225.js' defer></script> <script>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.4',blog:'106099430',post:'858455',tz:'0',srv:'neptunepine.com'} ]);
	_stq.push([ 'clickTrackerInit', '106099430', '858455' ]);</script> </body></html>